Security Update: TLS 1.0 and 1.1 Disabled on Turbo.net

Today we have removed support for TLS 1.0 and 1.1 for HTTPS connections to Turbo.net. TLS 1.2 is now required to use Turbo.net.

As a result, the minimum supported browser versions are now:

  • Apple Safari 7
  • Google Chrome 30
  • Microsoft Internet Explorer 11
  • Mozilla Firefox 27
  • Opera 17

This update improves the security of Turbo.net.

Note that Turbo continues to support executing earlier browser versions within Turbo containers.